Quick Fix, Veeam

Quick Fix: Can’t Log into Enterprise Manager due to Not Installed or Corrupt License

Had a situation today whereI needed to update the license for one of my Veeam Enterprise Manager isntances due to using ones from previous internal builds. My main Veeam Backup & Replication server that was connect to the Enterprise Manager instance already had a new license applied. When I went to log into the Enterprise Manager, I was presented with the following error. License is not installed or corrupted

After doing a quick search against that error, the only hits I was getting was to old forums posts suggesting that a full re-install was the only way to go. Not really a practical outcome. As it turns out the solution is pretty straight forward. In this circumstance, Veeam Backup & Replication will have a new license installed manually on the console. At the time of install it will warn you that the instance is connected and managed by an Enterprise Manager instance. If you proceed and install the license file manually, the license appears to be passed back to the Enterprise Manager once applied to Backup & Replication. What is required at that point to get past the error seen above, is to restart the Veeam Enterprise Manager service. Once the service has restarted you should be able to login and the license will be visible.

A Way to Avoid:

Obviously, the way in which this sort of situation is avoided is by using Enterprise Manager to report on and update the license automatically before it runs out via the License Information Tab under Notifications. For that you need to ensure you enable SMTP for email alerting. If you are a service provider, hopefully you are already managing your license keys through Veeam Availability Console which has excellent license management built in.

Leave a Reply

Your email address will not be published. Required fields are marked *

WordPress Appliance - Powered by TurnKey Linux